summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Stapelberg <michael+x200@stapelberg.de>2008-10-24 21:49:41 +0200
committerMichael Stapelberg <michael+x200@stapelberg.de>2008-10-24 21:49:41 +0200
commit8db7109e26daf823be7fe1fe92382bcebcd80761 (patch)
treedb5849e8cdf410d944d22edab5269b328782b6c8 /debian
parent7f39bf160ca6b69bf955344141721e564f3d6ee2 (diff)
Add debian packaging files to repository
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control15
-rw-r--r--debian/copyright29
-rwxr-xr-xdebian/rules80
5 files changed, 130 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..fc1ec07
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+wmiistatus (1.0-1) unstable; urgency=low
+
+ * Initial release
+
+ -- Michael Stapelberg <michael+mxallowd@stapelberg.de> Fri, 24 Oct 2008 21:30:42 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..f68d6b0
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,15 @@
+Source: wmiistatus
+Section: utils
+Priority: optional
+Maintainer: Michael Stapelberg <michael+wmiistatus@stapelberg.de>
+Standards-Version: 3.7.3
+Homepage: http://michael.stapelberg.de/wmiistatus
+
+Package: wmiistatus
+Architecture: any
+Priority: optional
+Section: utils
+Depends: ${shlibs:Depends}
+Description: little application to fill up wmii's status bar
+ wmiistatus is a program running in background and filling up wmii's status bar
+ using wmiis plan9 pseudo file system (therefore, you need 9pfs).
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..ceba04e
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,29 @@
+This Debian package is based on a tarball downloaded from
+http://michael.stapelberg.de/wmiistatus
+
+Copyright: (C) 2008 Michael Stapelberg <michael+wmiistatus at stapelberg dot de>
+
+Redistribution and use in source and binary forms, with or without modification,
+are permitted provided that the following conditions are met:
+
+* Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+
+* Redistributions in binary form must reproduce the above copyright notice, this
+ list of conditions and the following disclaimer in the documentation and/or other
+ materials provided with the distribution.
+
+* Neither the name of Michael Stapelberg nor the names of contributors
+ may be used to endorse or promote products derived from this software without
+ specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
+EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
+SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
+TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
+BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
+ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
+DAMAGE.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..5b1fe9e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,80 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+
+build-stamp:
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp config.status
+
+ # Add here commands to clean up after the build process.
+ [ ! -f Makefile ] || $(MAKE) distclean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/wmiistatus.
+ $(MAKE) DESTDIR=$(CURDIR)/debian/wmiistatus/ install
+ cp $(CURDIR)/wmiistatus.init $(CURDIR)/debian
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_prep
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+# dh_install
+# dh_installmenu
+ dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+ dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install