summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index b188641..110c4c8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,8 +18,8 @@
# Bash is easier
export SHELL = /bin/bash
-VERSION := $(shell head -1 debian/changelog | sed 's/.*(//;s/).*//')
-UPSTREAM := $(shell head -1 debian/changelog | sed 's/.*(//;s/-.?*).*//')
+VERSION := $(shell dpkg-parsechangelog --show-field Version)
+UPSTREAM := $(shell dpkg-parsechangelog --show-field Version | grep --only-matching '^[[:digit:].]\+')
# Last version that matches the database
LAST_VERSION := 3.0.12