summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control12
-rwxr-xr-xdebian/rules8
-rw-r--r--debian/source/format1
-rw-r--r--debian/swiftstory.init64
-rw-r--r--debian/swiftstory.postinst34
7 files changed, 125 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..5944b28
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+swiftstory (0.1) UNREALEASED; urgency=low
+
+ * source package automatically created by stdeb 0.8.2
+
+ -- Olivier Gayot <olivier.gayot@sigexec.com> Thu, 18 Aug 2016 12:48:06 +0000
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..a56af63
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,12 @@
+Source: swiftstory
+Maintainer: Olivier Gayot <olivier.gayot@sigexec.com>
+Section: python
+Priority: optional
+Build-Depends: python3-setuptools, python3-all, debhelper (>= 9)
+Standards-Version: 3.9.1
+
+Package: swiftstory
+Architecture: all
+Depends: ${misc:Depends}, ${python3:Depends}
+Description: SwiftStory game: We're not out of the woods yet.
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..1c29eac
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,8 @@
+#!/usr/bin/make -f
+
+# This file was automatically generated by stdeb 0.8.2 at
+# Thu, 18 Aug 2016 12:48:06 +0000
+export PYBUILD_NAME=swiftstory
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/debian/swiftstory.init b/debian/swiftstory.init
new file mode 100644
index 0000000..de1ae8f
--- /dev/null
+++ b/debian/swiftstory.init
@@ -0,0 +1,64 @@
+#!/bin/bash
+#
+### BEGIN INIT INFO
+# Provides: swiftstory
+# Required-Start: $remote_fs
+# Required-Stop: $remote_fs
+# Default-Start: 2 3 4 5
+# Default-Stop: 0 1 6
+# Short-Description: starts and Stop SwiftStory daemon
+### END INIT INFO
+
+set -e
+
+# /etc/init.d/swiftstory: start and stop SwiftStory daemon
+
+NAME=SwiftStory
+DESC='SwiftStory game'
+DAEMON=/usr/bin/swiftstoryd
+PIDFILE=/var/run/swiftstoryd.pid
+USER=swiftstory
+
+test -x $DAEMON || exit 0
+
+. /lib/init/vars.sh
+. /lib/lsb/init-functions
+
+[ -r /etc/default/swiftstory ] && . /etc/default/swiftstory
+
+export PATH="${PATH:+$PATH:}/usr/sbin:/sbin"
+
+case "$1" in
+ start)
+ log_daemon_msg "Starting $DESC" "$NAME" || true
+ if start-stop-daemon --start --quiet -b --oknodo --pidfile $PIDFILE --make-pidfile --chuid $USER --exec $DAEMON -- $OPTS; then
+ log_end_msg 0 || true
+ else
+ log_end_msg 1 || true
+ fi
+ ;;
+ stop)
+ log_daemon_msg "Stopping $DESC" "$NAME" || true
+ if start-stop-daemon --stop --quiet --oknodo --pidfile $PIDFILE --remove-pidfile; then
+ log_end_msg 0 || true
+ else
+ log_end_msg 1 || true
+ fi
+ ;;
+ reload|force-reload)
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ try-restart)
+ ;;
+ status)
+ status_of_proc -p $PID "$DAEMON" "$NAME" && exit 0 || exit $?
+ ;;
+ *)
+ log_action_msg "Usage /etc/init.d/swiftstory {start|stop|reload|force-reload|restart|try_restart|status}" || true
+ exit 1
+esac
+
+exit 0
diff --git a/debian/swiftstory.postinst b/debian/swiftstory.postinst
new file mode 100644
index 0000000..5874566
--- /dev/null
+++ b/debian/swiftstory.postinst
@@ -0,0 +1,34 @@
+#!/bin/sh
+# postinst script for swiftstory
+
+set -e
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <postinst> `abort-remove'
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+case "$1" in
+ configure)
+ adduser --system swiftstory --no-create-home
+ ;;
+
+ abort-upgrade | abort-remove | abort-deconfigure )
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0