summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog15
-rw-r--r--debian/control12
-rw-r--r--debian/i3status.postinst4
-rwxr-xr-xdebian/rules5
4 files changed, 29 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index b042309..76db42c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+i3status (2.3-1) unstable; urgency=low
+
+ * config search order is now ~/.i3status.conf, ~/.config/i3status/config,
+ /etc/i3status/config, then /etc/xdg/i3status/config
+ * battery: use POWER_NOW if CURRENT_NOW is not available (linux >= 2.6.36)
+ * use kill(0, pid) instead of /proc to check if a process is alive
+ * cache DNS query results also if there is no IPv6 connectivity
+ * implement the 'path' option for cpu_temperature
+ * add cpu_usage module
+ * automatically detect the output format unless configured specifically
+ * Bugfix: get time at the beginning of the loop
+ * Bugfix: respect locale settings (for %c in date format)
+
+ -- Michael Stapelberg <michael@stapelberg.de> Wed, 13 Jul 2011 16:25:53 +0200
+
i3status (2.2-1) unstable; urgency=low
* Implement a discordian date module (like ddate(1))
diff --git a/debian/control b/debian/control
index e6c58fb..fd5171e 100644
--- a/debian/control
+++ b/debian/control
@@ -4,8 +4,8 @@ Priority: extra
Maintainer: Michael Stapelberg <michael@stapelberg.de>
DM-Upload-Allowed: yes
Build-Depends: debhelper (>= 5), libiw-dev [!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386], libconfuse-dev, asciidoc, xmlto, libcap2-bin, libasound2-dev
-Standards-Version: 3.9.1
-Homepage: http://i3.zekjur.net/i3status
+Standards-Version: 3.9.2
+Homepage: http://i3wm.org/i3status
Package: i3status
Architecture: any
@@ -13,7 +13,7 @@ Depends: ${shlibs:Depends}, ${misc:Depends}
Recommends: dzen2 | xmobar, libcap2-bin
Enhances: dzen2, xmobar
Description: Generates a status line for dzen2 or xmobar
- i3status is a small program (less than 1000 SLOC) for generating a status bar
- for dzen2, xmobar or similar programs by combining several information about
- your system (IP addresses of your interfaces, load, current date/time, ESSID
- of the network you are associated to, disk status, and so on).
+ i3status is a small (about 1500 SLOC) and light-weight program for generating
+ a status bar for i3bar, dzen2, xmobar or similar programs by combining several
+ information about your system (IP addresses of your interfaces, load, current
+ date/time, ESSID of the network you are associated to, disk status, and so on).
diff --git a/debian/i3status.postinst b/debian/i3status.postinst
index 7a385c8..26eccc4 100644
--- a/debian/i3status.postinst
+++ b/debian/i3status.postinst
@@ -6,3 +6,7 @@ set -e
# issue as i3status only queries the speed, it does not change any
# configuration.
setcap cap_net_admin=ep /usr/bin/i3status || true
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/rules b/debian/rules
index c9c396c..2fa8f37 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,7 +9,10 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-build: build-stamp
+build: build-arch build-indep
+
+build-arch: build-stamp
+build-indep: build-stamp
build-stamp:
dh_testdir