summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Gayot <olivier.gayot@sigexec.com>2023-05-15 00:01:53 +0200
committerOlivier Gayot <olivier.gayot@sigexec.com>2023-05-15 00:03:54 +0200
commitebec1914c78c5588ce34de3f608b7e8e9d7b3ea2 (patch)
tree5e6c769dee26dbdaee385cdb4f544f45cbb4ebee
Add initial version (prepared for 0.1.0-1~ppa1HEADmaster
Signed-off-by: Olivier Gayot <olivier.gayot@sigexec.com>
-rw-r--r--debian/changelog7
-rw-r--r--debian/control30
-rw-r--r--debian/copyright32
-rw-r--r--debian/libargoat-dev.install3
-rw-r--r--debian/libargoat0.install1
-rw-r--r--debian/patches/0001-Replace-makefile-by-meson.build.patch101
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/source/format1
9 files changed, 180 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..d6ab037
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,7 @@
+argoat (0.1.0-1~ppa1) lunar; urgency=medium
+
+ * Initial release.
+ * Replaced upstream makefile by meson build system.
+ * Build-time tests are not run
+
+ -- Olivier Gayot <olivier.gayot@sigexec.com> Sat, 11 Feb 2023 22:00:19 +0100
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..4f9d03a
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,30 @@
+Source: argoat
+Section: libs
+Priority: optional
+Maintainer: Olivier Gayot <olivier.gayot@sigexec.com>
+Build-Depends:
+ debhelper-compat (= 13),
+ meson,
+ pkg-config,
+Standards-Version: 4.5.1
+
+Package: libargoat0
+Architecture: any
+Pre-Depends: ${misc:Pre-Depends}
+Multi-Arch: same
+Depends:
+ ${shlibs:Depends},
+ ${misc:Depends},
+Description: Lightweight library for command-line options parsing
+ This package includes the shared library.
+
+Package: libargoat-dev
+Section: libdevel
+Architecture: any
+Multi-Arch: same
+Depends:
+ libargoat0 (= ${binary:Version}),
+ ${shlibs:Depends},
+ ${misc:Depends},
+Description: Lightweight library for command-line options parsing
+ This package includes the development headers.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..af9e17f
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,32 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: cameltris
+Upstream-Contact: Olivier Gayot <olivier.gayot@sigexec.com>
+Source: https://git.sigexec.com/cgit.cgi/cameltris.git
+
+Files: *
+Copyright: Copyright (c) 2023 Olivier Gayot
+License: BSD-3-clause
+
+License: BSD-3-clause
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions
+ are met:
+ .
+ 1. Redistributions of source code must retain the copyright
+ notice, this list of conditions and the following disclaimer.
+ 2. Redistributions in binary form must reproduce the copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ 3. The name of the author may not be used to endorse or promote products
+ derived from this software without specific prior written permission.
+ .
+ THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
+ IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+ OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+ IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
+ INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+ NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+ THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/debian/libargoat-dev.install b/debian/libargoat-dev.install
new file mode 100644
index 0000000..3cca2bd
--- /dev/null
+++ b/debian/libargoat-dev.install
@@ -0,0 +1,3 @@
+usr/include
+usr/lib/*/libargoat.so
+usr/lib/*/pkgconfig
diff --git a/debian/libargoat0.install b/debian/libargoat0.install
new file mode 100644
index 0000000..d06c843
--- /dev/null
+++ b/debian/libargoat0.install
@@ -0,0 +1 @@
+usr/lib/*/libargoat.so.0*
diff --git a/debian/patches/0001-Replace-makefile-by-meson.build.patch b/debian/patches/0001-Replace-makefile-by-meson.build.patch
new file mode 100644
index 0000000..2d200fe
--- /dev/null
+++ b/debian/patches/0001-Replace-makefile-by-meson.build.patch
@@ -0,0 +1,101 @@
+From a99e4cb6a5f2e57449f6f22fd5a13fcf8dfce0f0 Mon Sep 17 00:00:00 2001
+From: Olivier Gayot <olivier.gayot@sigexec.com>
+Date: Sun, 14 May 2023 23:41:21 +0200
+Subject: [PATCH] Replace makefile by meson.build
+
+Signed-off-by: Olivier Gayot <olivier.gayot@sigexec.com>
+---
+ delete mode 100644 makefile
+ create mode 100644 meson.build
+
+diff --git a/makefile b/makefile
+deleted file mode 100644
+index 0fc4b52..0000000
+--- a/makefile
++++ /dev/null
+@@ -1,56 +0,0 @@
+-NAME = test
+-CC = gcc
+-FLAGS = -std=c99 -pedantic -g
+-FLAGS+= -Wall -Wextra -Werror=vla -Werror -Wno-unused-parameter
+-
+-BIND = bin
+-OBJD = obj
+-SUBD = sub
+-SRCD = src
+-TEST = test
+-
+-BINS = $(BIND)/argoat_sample_1
+-BINS+= $(BIND)/argoat_sample_2
+-BINS+= $(BIND)/argoat_sample_3
+-
+-INCL = -I$(SRCD) -I$(SUBD)/testoasterror/src
+-DEP = $(SUBD)/testoasterror/src/testoasterror.h
+-
+-$(OBJD)/%.o: %.c
+- @echo "building object $@"
+- @mkdir -p $(@D)
+- @$(CC) $(INCL) $(FLAGS) -c -o $@ $<
+-
+-all: $(DEP) $(BINS) $(BIND)/$(NAME)
+-
+-$(DEP):
+- @git submodule update --init --recursive
+-
+-$(BIND)/argoat_sample_%: $(OBJD)/$(SRCD)/argoat.o $(OBJD)/$(TEST)/argoat_sample_%.o
+- @echo "compiling executable $@"
+- @mkdir -p $(@D)
+- @$(CC) -o $@ $^ $(LINK)
+-
+-$(BIND)/$(NAME): $(OBJD)/$(TEST)/main.o $(OBJD)/$(SUBD)/testoasterror/src/testoasterror.o
+- @echo "compiling executable $@"
+- @mkdir -p $(@D)
+- @$(CC) -o $@ $^ $(LINK)
+-
+-run:
+- @cd $(BIND) && ./$(NAME)
+-
+-clean:
+- @echo "cleaning"
+- @rm -rf $(BIND) $(OBJD)
+-
+-github:
+- @echo "sourcing submodules from https://github.com"
+- @cp .github .gitmodules
+- @git submodule sync
+- @git submodule update --init --recursive --remote
+-
+-gitea:
+- @echo "sourcing submodules from personal server"
+- @cp .gitea .gitmodules
+- @git submodule sync
+- @git submodule update --init --recursive --remote
+diff --git a/meson.build b/meson.build
+new file mode 100644
+index 0000000..21221b5
+--- /dev/null
++++ b/meson.build
+@@ -0,0 +1,20 @@
++project('libargoat', 'c')
++
++src_libargoat = [
++ 'src/argoat.c',
++]
++
++pkgconfig = import('pkgconfig')
++
++lib_libargoat = library('argoat', src_libargoat,
++ version: '0.1',
++ install: true)
++
++install_headers('src/argoat.h')
++
++pkgconfig.generate(
++ filebase: 'libargoat',
++ name: 'LibArgoat',
++ description: 'Lightweight library for command-line options parsing',
++ version: meson.project_version(),
++ libraries: lib_libargoat)
+--
+2.39.2
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..5afec15
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-Replace-makefile-by-meson.build.patch
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..2d33f6a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,4 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)