summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOrestis Floros <orestisflo@gmail.com>2020-05-05 17:39:49 +0200
committerGitHub <noreply@github.com>2020-05-05 17:39:49 +0200
commit4bd07355abb1ad6b5463db7e7c763ea0075ebbc8 (patch)
tree9976f92f58a5593018c38fb82e4878ac3f1a83ca /configure.ac
parentae49ec4bcbb2474392851cea34d2d31a3d16eb4a (diff)
configure: Add switch to disable manual pages (#413)
Code copied from i3 Fixes #377
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 14 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 11caa33..3468cb1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,12 +114,20 @@ AC_PROG_MAKE_SET
AC_PROG_RANLIB
AC_PROG_LN_S
-AC_PATH_PROG([PATH_ASCIIDOC], [asciidoc], [no])
-AS_IF([test x"$PATH_ASCIIDOC" = x"no"],
- [AC_MSG_ERROR([asciidoc is required for generating man pages])])
-AC_PATH_PROG([PATH_XMLTO], [xmlto], [no])
-AS_IF([test x"$PATH_XMLTO" = x"no"],
- [AC_MSG_ERROR([xmlto is required for generating man pages])])
+AC_ARG_ENABLE(mans,
+ AS_HELP_STRING(
+ [--disable-mans],
+ [disable building manual pages]),
+ [ax_mans=$enableval],
+ [ax_mans=yes])
+AS_IF([test x$ax_mans = xyes], [
+ AC_PATH_PROG([PATH_ASCIIDOC], [asciidoc])
+])
+AS_IF([test x$ax_mans = xyes], [
+ AC_PATH_PROG([PATH_XMLTO], [xmlto])
+ AC_PATH_PROG([PATH_POD2MAN], [pod2man])
+])
+AM_CONDITIONAL([BUILD_MANS], [test x$ax_mans = xyes && test x$PATH_ASCIIDOC != x && test x$PATH_XMLTO != x && test x$PATH_POD2MAN != x])
AM_PROG_AR