summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorOlivier Gayot <olivier.gayot@sigexec.com>2023-02-12 00:18:03 +0100
committerOlivier Gayot <olivier.gayot@sigexec.com>2023-02-12 00:18:31 +0100
commit58adb09ef144beecfbb89b58c5735c0142c6f999 (patch)
treefba6bd7cec0bc22603767af0c1629567a5194e46 /meson.build
parent34500f10c7a306103ef8e38fb29f64e90c9ab122 (diff)
Load images from their installation directory
Signed-off-by: Olivier Gayot <olivier.gayot@sigexec.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index cc25b39..8ff2ca9 100644
--- a/meson.build
+++ b/meson.build
@@ -20,3 +20,11 @@ executable('camelsweeper', src_camelsweeper,
install: true)
install_subdir('img', install_dir: get_option('datadir') / 'camelsweeper')
+
+
+conf_data = configuration_data()
+conf_data.set('datadir', get_option('prefix') / get_option('datadir') / 'camelsweeper')
+
+configure_file(input: 'config.h.in',
+ output: 'config.h',
+ configuration: conf_data)