summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Gayot <olivier.gayot@sigexec.com>2018-03-13 13:41:24 +0000
committerOlivier Gayot <olivier.gayot@sigexec.com>2018-03-13 13:41:50 +0000
commitcf0dd78f7fb1f599f61d8e47ac7fa026fa4717d3 (patch)
tree8610e24a51648888ca9b8c727944295d30b37d9d
parent86d91f323bc05f56c734bef4cba8e6aecf80c54d (diff)
Changed the way the version parsing is done
Signed-off-by: Olivier Gayot <olivier.gayot@sigexec.com>
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index b188641..110c4c8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,8 +18,8 @@
# Bash is easier
export SHELL = /bin/bash
-VERSION := $(shell head -1 debian/changelog | sed 's/.*(//;s/).*//')
-UPSTREAM := $(shell head -1 debian/changelog | sed 's/.*(//;s/-.?*).*//')
+VERSION := $(shell dpkg-parsechangelog --show-field Version)
+UPSTREAM := $(shell dpkg-parsechangelog --show-field Version | grep --only-matching '^[[:digit:].]\+')
# Last version that matches the database
LAST_VERSION := 3.0.12