summaryrefslogtreecommitdiff
path: root/debian/README.svn
diff options
context:
space:
mode:
authorOlivier Gayot <duskcoder@gmail.com>2018-03-12 22:57:42 +0100
committerOlivier Gayot <duskcoder@gmail.com>2018-03-12 22:57:42 +0100
commita8c22829d8e8845cd4ddf4ef8b61a1ed79edfffc (patch)
treef0ae554b863266fbe523582d1be09216436c7472 /debian/README.svn
Imported from the SVN repository
http://svn.wolffelaar.nl/wsvn/phpbb/branches/jessie/ Signed-off-by: Olivier Gayot <duskcoder@gmail.com>
Diffstat (limited to 'debian/README.svn')
-rw-r--r--debian/README.svn110
1 files changed, 110 insertions, 0 deletions
diff --git a/debian/README.svn b/debian/README.svn
new file mode 100644
index 0000000..57f91d3
--- /dev/null
+++ b/debian/README.svn
@@ -0,0 +1,110 @@
+To build a new upstream source release from just the contents of the
+Subversion repository, proceed as follows:
+
+- get the original tar.bz2 file phpBB-$VERSION.tar.bz2, where e.g.
+ $VERSION=3.0.7-PL1 -- this can be achieved by running
+
+ debian/rules get-orig-source
+
+ if the changelog is up to date, and the upstream/phpbb3.info and
+ upstream/phpbb3-l10n-*.info files as well (the second ones can be
+ automatically updated using the update_languages scripts).
+
+- rename it phpbb3_$VERSION.orig.tar.bz2 (the script will do that for you)
+
+- do NOT just extract it to phpBB3, but into phpbb3-<VERSION>:
+
+ mkdir phpbb3-$VERSION && cd phpbb3-$VERSION && \
+ tar -xj --strip 1 -f ../phpbb3_$VERSION.orig.tar.bz2
+
+- move the debian folder in there,
+
+- get the language packs, which should already have been fetched by
+ the script, which in fact calls
+
+ debian/get-orig-source $VERSION l10n
+
+ which is a wrapper for getting package components,
+
+- make sure the downloaded stuff is NOT inside the phpbb directory
+
+.
+|-- phpbb3-3.0.7-PL1
+| |-- adm
+| |-- cache
+| |-- common.php
+| |-- config.php
+| |-- cron.php
+| |-- debian
+| |-- docs
+| |-- download
+| |-- faq.php
+| |-- feed.php
+| |-- files
+| |-- images
+| |-- includes
+| |-- index.php
+| |-- install
+| |-- l10n-ar
+[...]
+| |-- l10n-zh-cmn-hant
+| |-- language
+| |-- mcp.php
+| |-- memberlist.php
+| |-- posting.php
+| |-- report.php
+| |-- search.php
+| |-- store
+| |-- style.php
+| |-- styles
+| |-- ucp.php
+| |-- viewforum.php
+| |-- viewonline.php
+| `-- viewtopic.php
+|-- phpbb3_3.0.7-PL1.orig-l10n-ar.tar.gz
+[...]
+|-- phpbb3_3.0.7-PL1.orig-l10n-zh-cmn-hant.tar.gz
+`-- phpbb3_3.0.7-PL1.orig.tar.bz2
+
+- inside phpbb3-$VERSION,
+ extract the components e.g. like this (for .tar.xz only):
+
+ for i in ../*orig-*.tar.xz; do
+ dir=$(basename $i | sed 's/.*orig-\(.*\).tar.xz/\1/')
+ mkdir $dir && tar -xa --strip 1 -C $dir -f $i
+ done
+
+ Note that the (sole) leading directory is stripped, just as
+ dpkg-source would do.
+
+- Several files need to be taken care of, in case of a new upstream
+ release (see also README.source):
+
+ + debian/schema_data_debian.sql <- install/schemas/schema_data.sql
+ + debian/database_update_debian.php <- install/database_update.php
+
+ must be produced. The patches in maint-paches might come in handy.
+
+- build using your favorite tool: pdebuild, debuild -i [-us -uc]
+ [--lintian-opts --pedantic], ...
+
+.info files in upstream
+=======================
+
+get-orig-source will look at the filename of the info file in order to
+determine the .orig-XXX.tar.gz's name.
+
+The files have to be named <package>_<component>.info and must contain:
+
+ - Url
+ - Md5
+
+Optionally they may contain:
+
+ - Copyright
+ - Include (yes/no, default: yes)
+ - RepackDirectoryStructure (+/-<n>, default:0) adds or strips
+ trailing directories
+
+
+ -- J.M. Roth, April 2010