summaryrefslogtreecommitdiff
path: root/debian/export-sources
diff options
context:
space:
mode:
authorOlivier Gayot <duskcoder@gmail.com>2018-03-12 22:57:42 +0100
committerOlivier Gayot <duskcoder@gmail.com>2018-03-12 22:57:42 +0100
commita8c22829d8e8845cd4ddf4ef8b61a1ed79edfffc (patch)
treef0ae554b863266fbe523582d1be09216436c7472 /debian/export-sources
Imported from the SVN repository
http://svn.wolffelaar.nl/wsvn/phpbb/branches/jessie/ Signed-off-by: Olivier Gayot <duskcoder@gmail.com>
Diffstat (limited to 'debian/export-sources')
-rwxr-xr-xdebian/export-sources29
1 files changed, 29 insertions, 0 deletions
diff --git a/debian/export-sources b/debian/export-sources
new file mode 100755
index 0000000..011a16d
--- /dev/null
+++ b/debian/export-sources
@@ -0,0 +1,29 @@
+#!/bin/bash
+# $Id$
+
+# Use this script to create the .orig.tar.gz and .diff.gz in the current
+# directory
+
+set -e
+
+if [ -z "$1" ]; then
+ echo -n "Need to specify path to right version, like "
+ echo "tags/releases/phpbb3/3.0.6-1" >&2
+ echo "or trunk/phpbb3" >&2
+ exit 1
+fi
+
+mkdir export-sources.dir
+cd export-sources.dir
+
+echo Exporting...
+mkdir tmp
+cd tmp
+svn export http://svn.wolffelaar.nl/phpbb/$1 debian
+debian/rules get-orig-source
+cd ..
+GZIP=--best tar xzvf phpbb3_*.orig.tar.gz
+mv tmp/debian phpbb3-*
+rmdir tmp
+dpkg-source -b phpbb3-*
+