summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorOlivier Gayot <duskcoder@gmail.com>2013-12-26 15:23:45 +0100
committerOlivier Gayot <duskcoder@gmail.com>2014-01-18 13:44:42 +0100
commit6dd71f30872bb65d6959dd6ed2ac015c5739f98a (patch)
tree455843c7e1ff96f4fe76954aeb625eea0099b7ba /Makefile.am
parentbd9efbd97da6d97a1a19522fed29d3c9c4d7d91b (diff)
rb: use the autotools to generate the library
the library is not built using the autotools. the advantages of this improvement are: * we can do a make install / make uninstall / make dist / and so on * the library is not (unless specified) built as a shared and static library * some portability issues will be easier to fix.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..d5a7cd7
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,6 @@
+lib_LTLIBRARIES = librb.la
+librb_la_SOURCES = src/rb.c src/rb_str.c
+
+nobase_include_HEADERS = rb.h rb_str.h
+
+ACLOCAL_AMFLAGS = -I m4