summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOlivier Gayot <duskcoder@gmail.com>2013-12-26 15:23:45 +0100
committerOlivier Gayot <duskcoder@gmail.com>2014-01-18 13:44:42 +0100
commit6dd71f30872bb65d6959dd6ed2ac015c5739f98a (patch)
tree455843c7e1ff96f4fe76954aeb625eea0099b7ba /configure.ac
parentbd9efbd97da6d97a1a19522fed29d3c9c4d7d91b (diff)
rb: use the autotools to generate the library
the library is not built using the autotools. the advantages of this improvement are: * we can do a make install / make uninstall / make dist / and so on * the library is not (unless specified) built as a shared and static library * some portability issues will be easier to fix.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..93cc721
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,38 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
+AC_INIT([librb], [0.01], [duskcoder@gmail.com])
+
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_AUX_DIR([build-aux])
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_LIBTOOL
+AM_PROG_LIBTOOL
+
+AC_CONFIG_MACRO_DIR([m4])
+
+AM_INIT_AUTOMAKE([1.11 -Wall])
+
+LT_INIT
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_CHECK_HEADERS([malloc.h stdint.h stdlib.h string.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_INLINE
+AC_TYPE_SIZE_T
+AC_TYPE_UINT16_T
+AC_TYPE_UINT8_T
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_CHECK_FUNCS([strndup])
+
+AC_CONFIG_FILES([Makefile])
+
+AC_OUTPUT