summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOlivier Gayot <olivier.gayot@sigexec.com>2021-12-23 23:59:44 +0100
committerOlivier Gayot <olivier.gayot@sigexec.com>2021-12-24 00:16:12 +0100
commit1038ea323793c5f944e940585713c84dfea58ea1 (patch)
treeb4119c49bb1e0b40a417dc015eed6560071d3a6d /setup.py
parent2f2eef5c134eaffbac3db278ba71f153e19de54b (diff)
Don't include www in Python packagepython-package-no-www
The files in usr/share/swiftstory/www don't belong in the Python package. By making them not part of the package, we avoid errors when making symlinks to files that are provided by other Debian packages (e.g. libjs-jquery). Signed-off-by: Olivier Gayot <olivier.gayot@sigexec.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 5c4f5ce..8610d6a 100644
--- a/setup.py
+++ b/setup.py
@@ -4,11 +4,11 @@ from setuptools import setup, find_packages
prefix = '/'
-share_dir = 'usr/share/swiftstory/'
+data_files_prefix = 'usr/share/swiftstory/lang'
data_files = list()
-for n in os.walk('usr'):
+for n in os.walk(data_files_prefix):
if len(n[2]) == 0:
continue
@@ -18,8 +18,6 @@ for n in os.walk('usr'):
data_files.append((prefix + n[0] + '/', files))
-print(data_files)
-
setup(
name = 'swiftstory',
description = "SwiftStory game: We're not out of the woods yet.",