summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py35
1 files changed, 5 insertions, 30 deletions
diff --git a/setup.py b/setup.py
index a18c8d0..7c4c40c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,34 +1,9 @@
-import os
+""" Dummy setup.py to help pybuild figure out what to do until a Build-Depend
+on dh-python-pep517 can be added. """
-from setuptools import setup, find_packages
+from setuptools import setup
-prefix = '/'
-share_dir = 'usr/share/swiftstory/'
-data_files = list()
-
-for n in os.walk('usr'):
- if len(n[2]) == 0:
- continue
-
- files = list()
- for f in n[2]:
- files.append(n[0] + '/' + f)
-
- data_files.append((prefix + n[0] + '/', files))
-
-setup(
- name = 'swiftstory',
- description = "SwiftStory game: We're not out of the woods yet.",
- version = '0.1',
- author = 'Olivier Gayot',
- author_email = 'olivier.gayot@sigexec.com',
- packages = find_packages(),
- data_files = data_files,
- entry_points = {
- 'console_scripts': [
- 'swiftstoryd = swiftstory.__main__:main',
- ],
- }
-)
+if __name__ == "__main__":
+ setup()